crash when debugging is turned on

crash when debugging is turned on

Greetings,

II have crash when run on Windows MSVC and I hit F5 to run with debugger attached. after few actions I get dialog:

======

---------------------------
Microsoft Visual Studio
---------------------------
The debugger's worker process (msvsmon.exe) unexpectedly exited. Debugging will be aborted.
---------------------------
OK   
---------------------------

======
dialog to sent dump to MS reads:

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    msvsmon.exe
  Application Version:    12.0.21005.1
  Application Timestamp:    524f9c4c
  Fault Module Name:    ntdll.dll
  Fault Module Version:    6.3.9600.16408
  Fault Module Timestamp:    523d5305
  Exception Code:    c00000fd
  Exception Offset:    0000000000052e2e
  OS Version:    6.3.9600.2.0.0.256.48
  Locale ID:    1033
  Additional Information 1:    bf88
  Additional Information 2:    bf88fd355c14dcf55ea9e3a1a5fa749f
  Additional Information 3:    e712
  Additional Information 4:    e7129f01d567e84fac99ccbf926b7fdc

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
  C:\WINDOWS\system32\en-GB\erofflps.txt

best,

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.
9 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

and the dialog tom MSVC reads:

===

---------------------------
Microsoft Visual Studio
---------------------------
The debugger's worker process (msvsmon.exe) unexpectedly exited. Debugging will be aborted.
---------------------------
OK   
---------------------------

===

best,

vdm

.

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

But w/o debugger attached, everything goes smoothly, w/o iteruption.

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.
Peter Wang (Intel)的头像

I wonder that you reported the problem which is MSVC issue? 

1. Actually you didn't run VTune Amplifier XE anymore, ran F5 with debugger attached to cause this problem. Am I right?

2. Did it mean you met this problem after VTune integration installation, and cannot see this after uninstalling VTune Amplifier?

Thanks, Peter

iliyapolak的头像

I have the same issue.When I run VS debugger Visual Studio 2013 crashes so I switched to using windbg for testing my code at development stage.

Regarding @Marian case it seems that exception code is related to stack overflow.

 

 

iliyapolak的头像

@Peter

In my case the crash occurred after VTune integration.

Btw. few weeks ago a very similar issue was described in now defunct Parallel Studio forum when it was found that some of the Intel integrated debugger components caused infinite recursive function call.

Peter Wang (Intel)的头像

@ iliyapolak

Are you sure it was caused by VTune Amplifier XE? I mean if you uninstall the VTune integration, the problems goes.

Peter Wang (Intel)的头像

Thanks for this report. Would you please send me call stack info? Core dump file is too big...

Run "amplxe-feedback -create-bug-report <report archive>" after crashing, send logs.zip to us so engineering will investigate. Thanks again. 

iliyapolak的头像

@Peter

Yes because before the integration I was using VS debugger without any problem.In spare time I plan to investigate that issue more in depth.

登陆并发表评论。