Possible problem with IPP 8.1 and VS2012?

Possible problem with IPP 8.1 and VS2012?

 I just bought Intel Cluster Studio 2013 XE for Windows, I used the SN to login to Intel's website to download the latest package: Cluster Studio XE 2013 SP1 Update 1 for windows, built in Feb. 2014. 

 

Following the installation instructions, I installed all the packages here (including single and multi-threaded static libaries for IPP), the installation process itself is flawlessly, at least according to the installer.

The problem I met is (with Microsoft visual studio):

The integration with MS visual studio 2012 is bugged: IPP simply doesnt work properly:

(1) It give me unsolved symbol errors even if I enable IPP in VS2012 (I have used Parallel Studio 2013 before, so dont assume I dont know how to configure IPP in VS2012), therefore I have to manually add the necessary ipp lib files to the linker to build the binary;

(2), It seems that IPP will always use DLL libaries even if I set it to use ipp static libs in VS2012.

A evaluation version of Paralell Studio 2013 XE Update 4 and the IPP within it (I think it is version 7.11?) works perfectly with VS2012 on my machines, I dont know, if the problem is caused by (1) IPP 8.1 or (2)CS2013 SP1 Update 1 (3)Both.

Btw, if there any tech support hotline in China for Intel software.

2 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

yes, there are known issue with integration to IDE, but you can explicitly add the list of IPP libraries and header files to the Project Properties and we sure it will work,

I am not sure what you mean regard to item 2.  it's pretty easy to check if the executable linked with dynamic or static versions. Did you check it?

发表评论

登录添加评论。还不是成员?立即加入