atl projet visual studio 2013 assert error : too many categories defined

atl projet visual studio 2013 assert error : too many categories defined

hi

When i create a new atl project using visual studio 2013 (without add any code), when i try to compile it with intel c++ XE 14.0

i have this error :

Debug Assertion Failed!

program :
C:\travail\test_atl_2013_intel\x64\D_IC\test_atl_2013_intel.dll
file: c:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\atltrace.h
Line: 270

Expression: false && "Too many categories defined"

i have the same error for an atl old big project when i use visual studio 2013 with the intel c++ XE 14.0 compiler

(in visual studio 2012 i don t have this problem...)

How to solve it ?

Thanks in advance

regards

Michael

 

14 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

this solutions works for an empty atl projet created with visual studio 2013. (thanks...) But when i add an simple atl objet (for example Calculs) with : thread model free agregation : yes interface : dual with isupporterrorinfo enable and with connexion point enable i still have the same problem. (without add any code too...) And when i put all the *.cpp source (except stdafx.cpp) to precompiled header to use (/Yu) the same probleme with the same error still exists... So how to solve this case ? thanks in advance regards Michael

I have tried with an atl dll project, it can build fine even after adding a simple atl object with the same attribute as you have. Can you attach your test project?

1>  icl /Qvc12 "/Qlocation,link,C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin" /ZI /W3 /Od /Qftz- -D __INTEL_COMPILER=1400 -D WIN32 -D _WINDOWS -D _DEBUG -D _USRDLL -D _WINDLL -D _UNICODE -D UNICODE /EHsc /RTC1 /MDd /GS /Zc:wchar_t /Zc:forScope /Ycstdafx.h /FpDebug\vs2013-atl-dll3.pch /FoDebug\ /FdDebug\vc120.pdb /Gd /TP stdafx.cpp
1> 
1>  Intel(R) C++ Compiler XE for applications running on IA-32, Version 14.0.2.176 Build 20140130
1>  Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.
1> 
1>  stdafx.cpp
1>  icl /Qvc12 "/Qlocation,link,C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin" /ZI /W3 /Od /Qftz- -D __INTEL_COMPILER=1400 -D WIN32 -D _WINDOWS -D _DEBUG -D _USRDLL -D _WINDLL -D _UNICODE -D UNICODE /EHsc /RTC1 /MDd /GS /Zc:wchar_t /Zc:forScope /Yustdafx.h /FpDebug\vs2013-atl-dll3.pch /FoDebug\ /FdDebug\vc120.pdb /Gd /TP dllmain.cpp test1.cpp vs2013-atl-dll3.cpp
1> 
1>  Intel(R) C++ Compiler XE for applications running on IA-32, Version 14.0.2.176 Build 20140130
1>  Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.
1> 
1>  dllmain.cpp
1>  test1.cpp
1>  vs2013-atl-dll3.cpp
1>  icl /Qvc12 "/Qlocation,link,C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin" /ZI /W3 /Od /Qftz- -D __INTEL_COMPILER=1400 -D WIN32 -D _WINDOWS -D _DEBUG -D _USRDLL -D _WINDLL -D _UNICODE -D UNICODE /EHsc /RTC1 /MDd /GS /Zc:wchar_t /Zc:forScope /FoDebug\ /FdDebug\vc120.pdb /Gd /TC vs2013atldll3_i.c xdlldata.c
1> 
1>  Intel(R) C++ Compiler XE for applications running on IA-32, Version 14.0.2.176 Build 20140130
1>  Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.
1> 
1>  vs2013atldll3_i.c
1>  xdlldata.c
1>  xilink: executing 'link'
1>     Creating library C:\temp\vs2013-atl-dll3\Debug\vs2013-atl-dll3.lib and object C:\temp\vs2013-atl-dll3\Debug\vs2013-atl-dll3.exp
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========

i send you my test project

use the DIC (Debug Intel Compiler) configuration in x64

thanks in advance

regards

Michael

附件: 

附件尺寸
下载 test_atl_vs2013.7z62.58 MB

Michael,

You're right. I checked my old testcase again, it turns out I've disabled the "Register" after link. :(

I'll inform the compiler engineer about this, and see if it's possible to get it fixed soon. If I've any other workaround, will post here.

thanks,

Jennifer

Is there any update on this issue. When are we expecting a possible resolution.

I have exactly the same problem win MSVC 2013, ICC 14, x64 build, but only for debug builds (I guess because in release build asserts are removed by preprocessor, but magically my code is working well).

Though, I don't use MFC, but I do use ATL.

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

This problem is now solved with the last update

Thanks

Michael

Now I see the problem is not solved on my side. Using the latest ICC 14 for Windows x64.

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

Marián "VooDooMan" Meravý        

 Now I see the problem is not solved on my side. Using the latest ICC 14 for Windows x64.

could you post your build date of your icl? just type "icl" and it should print out the msg. The latest is update 3.

Jennifer

引文:

Jennifer J. (Intel) 写道:

could you post your build date of your icl? just type "icl" and it should print out the msg. The latest is update 3.

I'm sorry for the delay, I have just not noticed your post. Here you go:

c:\>"c:\Program Files (x86)\Intel\Composer XE 2013 SP1\bin\iclvars.bat" intel64
vs2013
Intel(R) Parallel Studio XE 2013 SP1
Copyright (C) 1985-2014 Intel Corporation. All rights reserved.
Intel(R) Composer XE 2013 SP1 Update 3 (package 204)


c:\>icl
Intel(R) C++ Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Ve
rsion 14.0.3.202 Build 20140422
Copyright (C) 1985-2014 Intel Corporation.  All rights reserved.

icl: command line error: no files specified; for help type "icl /help"

c:\>

It hurts so much, since I cannot use debug build at all.

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

bump ping?

-- With best regards, VooDooMan - If you find my post helpful, please rate it and/or select it as a best answer where applies. Thank you.

FYI

This issue is fixed in 14.0 update 3 and later, and as well as 15.0.

Jennifer

登陆并发表评论。