Internal Error running Memory Analysis

Internal Error running Memory Analysis

Hello,

Our test case stops with this message. Should I send you result directory for diagnosis?

[CmExecIntelInspector] Error: Internal error. Please contact Intel customer support team. [CmExecIntelInspector] Error: Internal error. Please contact Intel customer support team. [CmExecIntelInspector] Error: Internal error. Please contact Intel customer support team. [CmExecIntelInspector] Error: Internal error. Please contact Intel customer support team. [CmExecIntelInspector] Error: Internal error. Please contact Intel customer support team. 
[CmExecIntelInspector] Warning: Encountered an issue while loading result [/mnt/sda7/home/omneon/workspace/RmpFramework_DynamicAnalysis-1.0.x.0_mc_sdk_src-matrix/label/TST_LIN/RmpFramework_DynamicAnalysis/RMP/intelinspector_results/mi2_009]. Run terminated abnormally. Some data may be lost. 
[CmExecIntelInspector]   
[CmExecIntelInspector] 38 new problem(s) found 
[CmExecIntelInspector]     23 Invalid partial memory access problem(s) detected 
[CmExecIntelInspector]     10 Uninitialized memory access problem(s) detected 
[CmExecIntelInspector]     5 Uninitialized partial memory access problem(s) detected 
[CmExecIntelInspector] Result: 12
[CmExecIntelInspector] Intel Inspector exited [12]: Application returned a non-zero exit code and at least one problem detected

 

Thanks,

Frankie

 

4 帖子 / 0 全新
最新文章
如需更全面地了解编译器优化,请参阅优化注意事项

Yes.  Please send a result directory.  You can send it to me via private message if you don't want to post it

Mark

Hello,

      I am trying to run Intel Inspector 2013 update 9 linux version on my target application. My target application uses Intel DPDK to allocate memory(we use NUMA pages). I am successfully able to launch my application from Inspector but I see that Program is not getting terminated gracefully and Detector  shows No leaks detected.

 

These are the Commands that I ran

 1) source /opt/intel/inspector_xe_2013/inspxe-vars.sh
    export libraries needed to launch app
  inspxe-cl -collect mi1 -result-dir myRes007mi1 -- SWe_NP -c 0x5 -n 3 --proc-type=primary >> $npLog 2>&1 &(MYApp)

Launched app successfully

2) inspxe-cl -report status -report-output myRes007mi1

ERROR:Result Directory r@@@{@} is not found or empty. Suggestion - Specify a valid Path

3) The result directory got Created

inspxe-cl -report status -result-dir myRes007mi2 

=== Start: [2014/12/24 10:43:21] ===
Warning: Encountered an issue while loading result [/root/myRes001]. Run terminated abnormally. Some data may be lost.
=== End: [2014/12/24 10:43:23] ===

 0 Problems Found 

I suspect that memory leak exists in my Code. I purposefully Introduced one Leak, the tool is not able to detect it as the target app is not terminated gracefully. I need some inputs on how to overcome this issue and proceed further.

 

 

Thanks,

Preethi

 

 

 

 

 

Peter Wang (Intel)的头像

Please use latest Inspector XE 2015 Update 1 to verify this problem, again.

inspxe-cl -collect mi1 -result-dir myRes007mi1 -- SWe_NP -c 0x5 -n 3 --proc-type=primary >> $npLog 2>&1 &(MYApp)

inspxe-cl -report status -result-dir myRes007mi2 

=== Start: [2014/12/24 10:43:21] ===
Warning: Encountered an issue while loading result [/root/myRes001]. Run terminated abnormally. Some data may be lost.
=== End: [2014/12/24 10:43:23] ===

 0 Problems Found 

Did it run only 2 seconds? Was it expected duration? Can you run SWe_Np longer without Inspector XE? If yes, this is Inspector issue. Otherwise, you need to find root-cause from program itself. 

The warning message indicates that leaks cannot be detected if app aborted normally, but detected problems will be reported. For example, there was allocated memory not freed but application exited, you need to use option "-knob detect-leaks-on-exit=true" 

 

登陆并发表评论。