Intel® Cluster Ready

License File Activation

I just received my serial number of single user Intel Cluster Studio 2015 (Linux).  I had done product registration and generated a license file.  However, the license file generation page didn't show any information or steps of "how to apply the license file"...

I am using an evaluation version of Intel Cluster Studio 2015 in Linux workstation.   So, I want to use the above license file.  I copy the license file into /opt/intel/license folder.  Do I need to execute any command?  Is there any guidelines or info.

Thx.

MPI 5.0.2.044 Library Link Error

Hi, Everyone,

Under Linux OS, I built my MPI application with Intel MPI 5.0.2.044.  There is no error in compiling but there are following error in linking MPI library.

I am using the Intel MPI's  libmpifort.a and libmpi_mt.a for linking my application.

LIBS          = -L/opt/intel/composer_xe_2013_sp1.2.144/mkl/lib/intel64 -lmkl_intel_lp64 \
                -lmkl_intel_thread -lmkl_core /net/rdnas/home/dingjun/intel/impi/5.0.2.044/intel64/lib/libmpi_mt.a /net/rdnas/home/dingjun/intel/impi/5.0.2.044/intel64/lib/libmpifort.a

Intel MPI

Hello.

I am developing fault tolerant communicaction layer (MPI-like). So  this layer is slow now. 

Can I learn something about internal Intel MPI architecture to understand basic principles of big data transfering over different networks.

Can I also contact to developers of Intel MPI library to share experiences.

Nicolay.

Problem lauching mpiexec

Hello,

I do not succeed in lauching mpiexec. I'm working with Intel Fortran Compiler 11.1, and Intel parallel studio XE 2015, on windows 7.

In fact I'm using mpiexec to launch a hydraulic simulation with TELEMAC software (http://www.opentelemac.org). This software uses for parallel simulation MPICH2.

When I launch the command "mpiexec -n 4 xxx.exe", I'm asking to give my Account and my password. Is this password the password of the user of the computer? Or is it a password given by Intel with the installation?

Trying to use I_MPI_PIN_DOMAIN=socket

I'm running on an IBM cluster with nodes that have dual socket Ivy Bridge processors and 2 Nvidia K40 Tesla cards.  I'm trying to run with 4 MPI ranks using Intel MPI 5 Update 2 with a single MPI rank for each socket.  I'm trying to learn how to do this by using a simple MPI Hello World program that prints out the host name, rank and cpu ID.  When I run with 2 MPI ranks, my simple program works as expected.  When I run with 4 MPI ranks and use the mpirun that comes with Intel MPI, all 4 ranks run on the same node that I launched from.  I am doing this interactively and get a set of two node

Multiple Versions of Intel MPI Library Runtime on one machine

Hi Intel we appreciate all the time and effort you put into your products. We have a question about installing multiple versions of the Intel MPI Library Runtime Environment on one machine.

How can one have multiple versions of the Intel MPI Library Runtime Environment installed on the same machine? We are asking because some versions of our software use 4.0 and some use 4.1. In the near future another version may use 5.0. There seems to be a conflict because the Windows services all use the same name. 

Thanks for the great products,

Adam Bruss

How to initiate MPI in the Fortran subroutine?

Hi, All,

I am using Intel MPI and OpenMP. My application is a hybrid MPI and OpenMP Fortran-code application. Currently it is tested on a multicore computers. My question for you is as follows:

Can I initiate MPI processes and  run all MPI subroutines  within a Fortran subroutine?

The details are given as follows:

program xsamg2014

implicit none

..........................

/* Before calling xsamg, all codes are only OpenMP codes */ 

/*OpenMP Fortran codes  */

.....................................

订阅 Intel® Cluster Ready