Media

Suggested Format to be used for filing Forum Questions for a Quicker Turnaround

Legal Disclaimer

The below given format is a highly recommended way to file a question on Media SDK Forum page. This gives support team a better idea of the issue which often results into a quicker turn around time.

Please give all this information -

Anticipated direction info for Media SDK 2015 for Linux Servers

In the spirit of open communication, we've assembled current plans for our 2015 Linux product. This includes some changes in supported Linux distributions and hardware.  

For more information please see the article below:

https://software.intel.com/en-us/intel-mediasdk-supported-versions-server

Any feedback you may have is appreciated.  Thanks!

 

vainfo seg-faults on Ubuntu14.10 on i7-4790K

Hi,

I can't get Media SDK to work. vainfo seg faults trying to write to 0x18.

Here' s my install steps:

Install fresh Ubuntu 14.10

#########################################################
# Add necessary components

sudo apt-get install build-essential git yasm cmake libtool libc6 libc6-dev

 

#########################################################

 

graphic blending with video

Hello,

I am new with media service SDK, and interested in its linux branch.

I have read the "Intel® Media SDK 2014 Developer’s Guide "

I did not find reference to graphic blending with video (for example when there is need to blend some picture or symbol with video).

Can anyone give a hint as to how this is supported with the media SDK ?

Best Regards,

Ran

system hang when call IDirect3DDevice9::UpdateTexture on E3845

We use Intel_EMGD.WIN7_PC_Version_36_15_0_1127 driver and media SDK hardware decoding and display on Baytrail E3845 platform, it's ok if we run hardware decoding or display seperately.If we put hardware decoding and display together, system will hang when calling IDirect3DDevice9::UpdateTexture.We use Direct3D API.  Any suggestion is appreciated. Thanks. 

i965_drv_video.so not found on CentOS 7.1

Hi there,

We tried to switch our development from SLES11 / MSS R3 to CentOS 7.1 / MSS R6. While I am setting up CentOS 7.1, I found that the MSDK won't run. libva is looking for /usr/lib64/dri/i965_drv_video.so which is not found on the system. 
I workaround the issue by soft-link i965_drv_video.so to iHD_drv_video.so. Then, everything works!

MFXVideoVPP_RunFrameVPPAsync returns MFX_WRN_DEVICE_BUSY

Currently my project has a requirement of using VPP pre-proc and post-proc together in the transcoding pipeline. As proof of concept I modified the existing sample_multi_transcode example where the goal is to convert NV12->RGB4 and then convert back from RGB4->NV12 both the operation using VPP. As i understood 2 instances of VPP cannot be run with a single mfx session, hence used MFXCloneSession and MFXJoinSession for using VPP2.

订阅 Media